Hola que tal, les cuento que instale la ultima version de android studio pero al crear un proyecto me salta este error
*
Imagen
ya me arte de buscar soluciones y no le acerte aun 
*
Imagen
*
saludos indetectables !
ya no juego en Android, pero no tendras mal algo en el build.gradle?
veo que po lo general viene por ese lado
[Enlace externo eliminado para invitados]

Código: Seleccionar todo

{******************************************************************************}
{** WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING  **}
{******************************************************************************}
{**                                                                          **}
{** The prototypes, declarations and information in this file has been       **}
{** compiled from various sources as well as through reverse engineering     **}
{** techniques. We make no guarantee as to the correctness of the contents.  **}
{** Caution is recommended, USE AT YOUR OWN RISK.                            **}
{**                                                                          **}
{******************************************************************************}
DSR! escribió: 23 Ene 2022, 02:07 ya no juego en Android, pero no tendras mal algo en el build.gradle?
veo que po lo general viene por ese lado
[Enlace externo eliminado para invitados]
use esta solucion ya que es la version de android studio que tengo :

Actualicé mi estudio de Android a la última versión: Android Studio - Arctic Fox | 2020.3.1 Entonces mostraba este error. Para solucionar este error, tienes que seguir estos pasos:
Archivo>estructura del proyecto>proyecto
Cambiar la versión del complemento Gradle de Android: 7.0.0 y la versión de Gradle: 7.0.2
luego vaya a archivo> configuración> compilación, ejecución, implementación> herramientas de compilación> Gradle
cambie Gradle JDK a la versión 11 si es la versión 1.8.
si la ventana emergente de notificación para Gradle se actualizó, tóquela y haga clic en ejecutar los pasos seleccionados .
sincronice el proyecto y reconstruya su proyecto si es necesario
.

pero no sirvió
luego hice un build --warning-mode all para ver los errores y me sale esto : ( lo raro es que no me sale instalado los emuladores tampoco)
Imagen
build --warning-mode all:

Código: Seleccionar todo

FAILURE: Build completed with 2 failures. 1: Task failed with an exception. ----------- * What went wrong: Execution failed for task ':app:checkDebugAarMetadata'. > A failure occurred while executing com.android.build.gradle.internal.tasks.CheckAarMetadataWorkAction > One or more issues found when checking AAR metadata values: The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.appcompat:appcompat:1.4.1. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\f3d2b19013a7fb3d07666b1f565a4297\transformed\appcompat-1.4.1\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.appcompat:appcompat-resources:1.4.1. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\bc6a00a686841274988a71919fdf131a\transformed\jetified-appcompat-resources-1.4.1\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.emoji2:emoji2-views-helper:1.0.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\ab1fb684081fbb6647fb13818867f241\transformed\jetified-emoji2-views-helper-1.0.0\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.emoji2:emoji2:1.0.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\b31cdb3ac9a0f35e2b63c77126c3b8fb\transformed\jetified-emoji2-1.0.0\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.core:core:1.7.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\ecfe5acaac99ad11938155bd9a23dc3f\transformed\core-1.7.0\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.lifecycle:lifecycle-process:2.4.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\a13f3a516dde542f0806557e528447a0\transformed\jetified-lifecycle-process-2.4.0\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.lifecycle:lifecycle-runtime:2.4.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\9650bed99aafc91ba0e295a91b63e0e7\transformed\lifecycle-runtime-2.4.0\META-INF\com\android\build\gradle\aar-metadata.properties. * Try: > Run with --stacktrace option to get the stack trace. > Run with --info or --debug option to get more log output. > Run with --scan to get full insights. ============================================================================== 2: Task failed with an exception. ----------- * What went wrong: Execution failed for task ':app:checkReleaseAarMetadata'. > A failure occurred while executing com.android.build.gradle.internal.tasks.CheckAarMetadataWorkAction > One or more issues found when checking AAR metadata values: The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.appcompat:appcompat:1.4.1. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\f3d2b19013a7fb3d07666b1f565a4297\transformed\appcompat-1.4.1\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.appcompat:appcompat-resources:1.4.1. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\bc6a00a686841274988a71919fdf131a\transformed\jetified-appcompat-resources-1.4.1\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.emoji2:emoji2-views-helper:1.0.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\ab1fb684081fbb6647fb13818867f241\transformed\jetified-emoji2-views-helper-1.0.0\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.emoji2:emoji2:1.0.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\b31cdb3ac9a0f35e2b63c77126c3b8fb\transformed\jetified-emoji2-1.0.0\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.core:core:1.7.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\ecfe5acaac99ad11938155bd9a23dc3f\transformed\core-1.7.0\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.lifecycle:lifecycle-process:2.4.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\a13f3a516dde542f0806557e528447a0\transformed\jetified-lifecycle-process-2.4.0\META-INF\com\android\build\gradle\aar-metadata.properties. The minCompileSdk (31) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-30). Dependency: androidx.lifecycle:lifecycle-runtime:2.4.0. AAR metadata file: C:\Users\user\.gradle\caches\transforms-3\9650bed99aafc91ba0e295a91b63e0e7\transformed\lifecycle-runtime-2.4.0\META-INF\com\android\build\gradle\aar-metadata.properties. * Try: > Run with --stacktrace option to get the stack trace. > Run with --info or --debug option to get more log output. > Run with --scan to get full insights. ============================================================================== * Get more help at https://help.gradle.org BUILD FAILED in 1m 12s 48 actionable tasks: 48 executed 14:13:01: Task execution finished 'build --warning-mode all'.
Responder

Volver a “Java”